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II. Client Installation: API Installation |

Initial Steps in client workstation where SAP BO Bl Client Tools are installed
Unzip file (see content in previous slide).
Read “Version.txt” included in the root folder of zip file to review release.
Read license files in “License” folder to understand the limitations and rules related to this connector.
Copy from “[Path where SBOPRepositoryExplorer Unziped]\dataAccess\connectionServer\open” folder
to
“[Path where SAP BO is installed]\SAP BusinessObjects Enterprise Xl 4.0\dataAccess\connectionServer\open”
Files: “SBOPRepositoryDriver.prm” and “SBOPRepositoryDriveren.cod”.
In previous destination folder edit “open.sbo” file and insert between “<DataBases>...</DataBases>" next content:

<DataBase Active="Yes" Name="SBOP Repository Explorer">
<Class JARFile="dbd_SBOPRepositoryDriver">com.jmlds.sboprepositoryexplorer.SBOPRepositoryDriver</Class>
<Parameter Name="Extensions">SBOPRepositoryDriver,open</Parameter>
<Parameter Name="Description File">SBOPRepositoryDriver</Parameter>
<Parameter Name="SQL Parameter File">SBOPRepositoryDriver</Parameter>
<Parameter Name="Max Rows Available">Yes</Parameter>
<Parameter Name="Connection Shareable">Yes</Parameter>
<Parameter Name="Shared Connection">Yes</Parameter>
</DataBase>



lIl. Client Installation: API Installation I

Initial Steps in client workstation where SAP BO Bl Client Tools are installed

Copy from “[Path where SBOPRepositoryExplorer Unziped]\dataAccess\connectionServer\open\drivers\open” folder
to
“[Path where SAP BO is installed]\SAP BusinessObjects Enterprise Xl 4.0\dataAccess\connectionServer\open\drivers\open”
(In SAP BO BI 4.1 does not exist this last path, so you must copy same structure and content (“..\drivers\open”) inside of top open folder.)

from: [UNZIPED FOLDER SBOPRepositoryExplorer]\dataAccess\connectionServer\open\drivers\open

| arklr-3.1, 1-runkime. jar

cache. jar
— ] . cache. jar
| | config.properties, sample | commons-cadec-1.3.jar
] ||:";|4j . jar || commons-lagging-1.1.1.jar
|| commons-net-2.2, jar
|| poi-3_10.jar ] httpclient-4,0,3. jar
|4 poi-dom4j-1.6.1 . jar |i&] hictpcore-4.0.1.jar
. . . logi.jar
|| poi-ooxml-3_10,jar B oois 10.jar

4| poi-ooxml-schemas-3_10,jar
|| poi-skax-api-1.0,1.jar
| poi-xmlbeans-2.3.0.jar

|| SEOPRepositaryDriver, jar

to: [SAP BO INSTALL PATH]\SAP BusinessObjects Enterprise XlI 4.0\dataAccess\connectionServer\open\drivers\open



V. Client and Server Installation: BUG In 4.1 SPx

In version 4.1 SPx for WRC and Server Side, doesn't works in DDK the function to read CONFIGURATION parameters from SAP BO .COD files used in connection

definition. We provide for you three options until SAP provide the patch: =]
a) get those parameters from environment variables: ~User wariables For Adminiskrakor
. . ‘ariable | Walue |
For |OgS and debugglng' PATH D:horacle_clientZz2biproducth11.2.00kin

SBOPREPEXP_TRACELOG_HERETHECMSNAME=YES_TRACE or NO_TRACE TEMP D:\Temp
SBOPREPEXP_TRACEFILE_HERETHECMSNAME=path_to_file for example C:\SBOPREpositoryExplorer.log " e
SBOPREPEXP_LOGLEVEL_HERETHECMSNAME=Debug or Error

To import XML Files:
SBOPREPEXP_XMLFILE_ HERETHECMSNAME=path_to_xml_file for example C:\Samples\Samples.xml

e, . | Edit. .. Delete |

—Syskem variables

‘ariable | Yalue ﬂ
To import EXCEL Files: SBOPREFEXP_EXCELFILE_EI4  (C:\TEMP\SamplestSampleExce
SEOPREPEXP_LOGLEVEL EI4 Debug —
SBOPREPEXP_EXCELFILE_ HERETHECMSNAME=path_to_excel_file for example C:\Samples\Samples.xIsx SEOPREPERP_MAXQUERYOBJE... 100000 -
To set Query Limits: 4 I i
SBOPREPEXP_MAXQUERYOBJECTS HERETHECMSNAME=Query_limit hew... | ExR | Delete |
b) create a file called config.properties in same folder where SBOPRepositoryDriver.jar with next parameters: | |
AnNCel

MAX_OBJECTS_QUERY=Query_limit

TRACELOG=Yes_Trace or No_Trace
TRACE_FILE=Path_to file_for logs_in_JAVA_ Format (use / for path)
LOGLEVEL=Debug or Error

XML_FILE=path_to_xml_file (use / for path)
EXCEL_FILE=path_to_excel_file (use / for path)

MAX OBJECTE QUERY=100000

TRACELOG=Tes Trace
TRACE_FILE=C:ISBOPREstitDrgExplDrerTraceLDg.txt
LOGLEVEL=Debug

ZML FILE=C:/TEMP/Zamples/TakleSamples.xml

EXCEL FILE=C:/TEMP/Samples/SampleExcel.xlsx

[T Wy [ = AV R oy o

c) user environment variable with path of config.properties file:
SBOPREPEXP_CONFIG_FILE=path_to_config_properties_file(must_include_file_name)



V. Client Installation: Import Universe

Universe Import using IDT (Information Design Tool)

Open IDT (Information Design Tool)
Create a new project (For example: File = New = Project = SBOPRepositoryExplorer)

Import the universe delivered in ZIP file (inside of Basic Universe folder). Select project already created - File = Retrieve a Published
Universe = From a Local Folder

Select to import the “SBOPRepositoryExplorer.unx” included in folder “Basic Universe” folder.
“"-n,.linI Information Design Tool

SBOPRepositoryExplorerFree

Import universe SBOPRepositoryExplorer.unx

Create project in IDT

B information design tool

*File Iﬁ Edit Window Help
s 3 [
= | Copy Chrl+-C i = -7 ?geu:n Proiact g '_J IE i J i) .
Faste ChrlH-Y l;&Relatinnal Conneckion s Jne ] E‘m] SBOPRepositoryExplorerFres
2% Delete '-'iL—OL":"F' Connection iZlose hr |44 - E|[£7 r‘Etri'\v‘|-2I:I14-5-14-Ell-5EI-4?
leyidis - Data Foundation Close Al CEr|+Shift-+ > - ':-Ei'i-i'F'F!-EF":'st-:'r":-'E::-::F-h:-r'er'-I:-l::-::
Renarme. .. Fz2 il Project """ j_; 5 SBOPRepositoryExplorer . dfx
y Javs Chrl+5 Lol SBOPRepositorvExplorerLocal or

Save Al Zhr S hift+5
Publish k
Frimt:
Retrieve a Published Universe » %me a Repositary. ..
Convett .uny Universe. .. %t From a Local Folder., ..

.o



VI. Client Configuration: Configure Connection

Configure Connection using IDT (Information Design Tool), locally.

Ellj] SBOPRepositoryExplorerFree
EIE: retrieval-2014-05-14-01-50-47
----- = SBOPRepositorvExplorer. bl

------ 3_;3 SBCPRepositoryExplorer, dfx
SBOPRepositoryExplorerLocal . cri

In IDT into the project already created, edit the local connection “SBOPRepositoryExplorerLocal.cnx”

Edit Relational Connection
i} Edit Relational Connection . ] .
Edit SBOP Repository Explorer connection (2/2)

Edit SBOP Repository Explorer connection (1/2)

Max Objects per Query | {nnnon

=

Cuskomer Mame I SMAPSPACE Active Log? IND
License Key | File: Log Path | CHIMLDS_SBOPRepositoryExplarer.log
System{CMS) I bt Log Level IDeI:nug

o _ Personal Tables (=ML |G:'|,BIN'|,sI:uDprepu:nsitDr3-'expIu:nrer'|,SBOPRepu:nsitor\,-'Ex|:|Iu:nrerFree'l,SampIes'l,TabIeSamples.xml
Buthenticakion IEnterprlse

Personal Data (xL3) I GBI sboprepositoryexplorer!, SBOPRepositoryExplorerFresl Samplest SampleExcel s
Lsernarme | Administrator _ _ _

Connection Pool Mode IDlsconnect after each kransaction
Password I tassscee Pool Timeout IE,D _% Minutes

Array Fetch Size 100 —

Max Objects per Query: this is the
TOP in individual SELECT TABLE
queries

Active Log in case of trace errors or
debugging

Personal Tables (XML) to create
tables using CMS SQL queries.

Personal Data (Excel) to import
data to tables from an Excel.

Connection Pool Mode and Pool
Timeout to manage connection
timeout

Array Fetch Size to control query
blocks size

Fill next required fields: Customer Name (your name/company name), System(CMS), Authentication, Username and Password

* The License Key field in this step is not required and to use in free mode you must request your free license (see next topic request free license)



VIl.Request License: Obtain the Serial ID

License Key Request using IDT

Why must | request License Key? You must request a license key because it is a free version and we want to know how many people are
using this connector.

What is included in this Free version?

Without License Key: you can view only one row per table

With License Key: you can view 1.000 rows per table (thinking in small and medium SAP BO BI customers)
What are the differences between the commercial and noncommercial version?

Non-Commercial Commercial
Limit rows per table to 1.000 No row limit per table
Reports are not included Reports are included
No support and maintenance Full support and maintenance

Request new features (SLA)

After configure connection to request your free license key you must send the SI_SERIALID . | . .c (360 ms)

provided in table IMLDS _SNAPSPACE_GETSERIALID. You can go to Max RDW5| o000 =
SBOPRepositoryExplorer.dfx and expand connection SBOPRepositoryExplorer m Sl Distinct Values

Filtered rows: 1)1

to see list of tables, then select mentioned table (JMLDS__ SNAPSPACE_GETSERIALID) |
and select Show Table Values option. From the unique field SI_SERIALID select and copy

5I_SERIALID

MT Az 1 4L Fr b dShkSHY T IS mEY My pzvIRGUZ .

the line and send to info@snapspace.pt to request the license key used in next step.



mailto:info@snapspace.pt

VIlI.Configure License Key

Configure License Key using IDT (Information Design Tool) for connection already configured.
After receive the license key, in IDT into the project already created, edit the local connection “SBOPRepositoryExplorerLocal.cnx”

El[j] SBEOPRepositoryExplorerFree
EI[E: rekrieval-2014-05-14-01-50-47

=nj

-T2 SBOPRepositorvExplorer. bl

------ j_;j SBOPRepositoryExplorer, dfx
SBOPRepositoryExplorerLocal . crnx

It is important no change Customer Name and System (CMS) because License Key is associated to those parameters.

B Edit Relational Connection

Edit SBOP Repository Explorer connection (1/2)

Customer Name | SNAPSPACE (JORGE SOUSA)
License Key | I

System(CM5)  [bi4

After License Key is provided and set you must save changes and restart IDT.
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IX. Test in IDT: Retrieving data from CMS Server

Using IDT (Information Design Tool) to explore and test SBOPRepositoryExplorer connector.

When all configurations where done in client tools side we must test if we can retrieve data from CMS. Here you can find next examples:

Select Folder Structure in SBORepositoryExplorer.dfx:

'y LInformation Design Too

File Edit Window Help
p— - - ral | "ST 4l ITHOR" :
# FOLDERS Insert v L | D) - & | = X |w B3| BHE| oM
"51 IDII {EEI . -
"SI_CUID" 21| [nsert Calculated Column -4 SBOPRepositaryExplarer, dfx - Show values in table FOLDERS, 23
"ST MAME" 38 ' . Show values in table FOLDERS. - 403 rows (22387 ms)
= ZEdi...
"SI_DESCRIPTION"
"] PARENTID" E:;,—?-,‘:; o 3 " RawData | T3 Distinct values 11 Analysis
"SI CMWWMER" Set Cass To , Filtered rows; $03/403
SI_CWNERID Replace by 3 st o | st cun | SI_PATH | SI_MAME | SI_DESCRIPTION | SI_PAREMTID
"SI_CREATION_TIME  pepect 3 3931 AClakZlzisvl,., | LCM <Ml 0
"SI_UPDATE_TS" Change Qualifier/Owner ... 3941 AvtUSjcgpxFs...  \DEFALLT Probes <Mull > 5435
"SI_PaTH" 4006 Frksrkkctach, .. \DEFAULT Data Federation <kl G435
"SI FLAGS" ':""”t ettt 4024 AY9z15EgaFS... | \DEFALLT Report Canver... | <kl 5435
"SI OBTYPE" &8 Show Table Yalues. . 4054 AdExBN2]_9...  \DEFALULT visual Difference <M= 2438
Pl DU Ey 'R D B B T N

Select some fields from Connections, Universes and Documents at the same time (in SBOPRepositoryExplorer.blx = Queries) :
’; 9| i:i'-| [ Wigw script ‘
4 Universe : SBOPRepositoryExplorer

O % X 2l

<8 -

_IMLDS_SMNAPSPACE _INFORMATION |

Applications

Fuoldets

Categaries

Documents
Dacument 10
Dacurnent CUID

Cocument Mame
Docurnent Description
Dacument Kind
Document Parent ID
Document Owiner

Document Cwner [0
Dacument Author

Fiewiirnank Ceasbinn Time

L_JJ Result Objects for Query #1

Connection Mame Universe Name | |

fH partial Results {200 rows - 55227 ms)

Max Rows | 200 2

efashion eFashion Charting Samples
Fold Unfold Sample

efashion-webi

efashion

M | Monitoring TrendDB Connection

eFashion Input Contrals And Charts
Input Contrals and wariables

eFashion Formatting Sample

Monitoring TrendData Universe MonicoringTrend Data-Sample
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X. Publish the Connection and Universe to CMS

Publish connection and universe to the CMS repository using IDT (Information Design Tool).

In IDT into the project already created, select the local connection “SBOPRepositoryExplorerLocal.cnx”

EI[j] SBOPRepositoryExplorerFree
== retrieval-2014-05-14-01-50-47 5

o T SBOPRepositarvExplarer, bl

- T SBOPRepositoryExploter bl j;j EEOPREPDSItDWExp|Drer dFx

------ 3; 3 SBOPRepositoryExplarer, dfx R = i wEx

: SBOPRepositoryExplorerLocal .o

In File = Publish = Publish Connection to a Repository

Change data foundation (SBOPRepositoryExplorer.dfx) pointing to the connection short cut (secured connection):
SBOPRepositoryExplorerLocal.cns

_.13_.1 SEOPRepositoryExplorer,.dfx 23 l

j;j *SROPRepositaryExplorer, dfx &3

&1 Connection Master —
& @& | * = Bt|| sk Inset -~ D > --i'f SECPRepositoryExplorerLoce Secured [@EI4 = & Connection
Ell;fk__ i L sEOPRepositaryExplorerLoce Local l.} & 2 | v =

= [:] 5, [Z»Open

- [ IMLDS__SNAF
- IMLDS__SNAF A Test...

I === P

L:E SEOPRepositoryExplorerLocal [@EBI4

W:Change...

After save the datafoundation you can publish the universe to CMS: Select SBOPRepositoryExplorer.blx = Right Button - Publish = To

a Repository.

12



Xl. Server Installation: API Installation

Steps in server side where SAP BO Bl WeblProcessingServer is installed
Like in client tools installation, we must follow topic Il and 11l (Client Installation: API installation | & I1)
Copy from “AdataAccess\connectionServer\open” folder
to
“[Path where SAP BO is installed]\SAP BusinessObjects Enterprise Xl 4.0\dataAccess\connectionServer\open”
Files: “SBOPRepositoryDriver.prm” and “SBOPRepositoryDriveren.cod”.
In previous destination folder edit “open.sbo” file and insert between “<DataBases>...</DataBases>" next content:

<DataBase Active="Yes" Name="SBOP Repository Explorer">
<Class JARFile="dbd_SBOPRepositoryDriver">com.jmlds.sboprepositoryexplorer.SBOPRepositoryDriver</Class>
<Parameter Name="Extensions">SBOPRepositoryDriver,open</Parameter>
<Parameter Name="Description File">SBOPRepositoryDriver</Parameter>
<Parameter Name="SQL Parameter File">SBOPRepositoryDriver</Parameter>
<Parameter Name="Max Rows Available">Yes</Parameter>
<Parameter Name="Connection Shareable">Yes</Parameter>
<Parameter Name="Shared Connection">Yes</Parameter>
</DataBase>

Copy from “AdataAccess\connectionServer\open\drivers\open” folder

to
“[Path where SAP BO is installed]\SAP BusinessObjects Enterprise Xl 4.0\dataAccess\connectionServer\open\drivers\open”
(In SAP BO BI 4.1 does not exist this last path, so you must copy same structure and content (“..\drivers\open”) inside of top open folder.)

Sometimes if the connector is already in use is required restart of Weblntelligence Processing Servers.
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Xll. Test in Web Intelligence: Create a simple report S“UQ,,SPUCB

Using Bl Launch Pad (Webl) or using WRC (Web Intelligence Rich Client) to explore and test SBOPRepositoryExplorer connector.

When all configurations where done in client tools side and in server side we must test if we can retrieve data from CMS using WRC or Webl by
BlLaunchPad. Here you can find one example:

m Select some fields from Users and Groups at the same time using the universe published to CMS (SBOPRepositoryExplorer):
1 E; Query Panel
t'j’:_’i.ﬁ.dd@uery - EEEE‘ @ i< JE]

% Universe outline (I Result Objects

. - |
ainEils Ve | 1 Group Mame || i Group Path I| 1 Lser Name I| i User Last Logon Time

€8 « |Type here to filter on H+ =t z

® [ Schedules o~
® [ Instances

B =" Users 7 Queny
WEFY|
1 Uszer ID .

User CUID 7o filter tfy niverse pane and 2dd them fhere |
User MName spedfy th ot o define 3 message 50 Users.

Iser Full Mame -
[

zer Email Address g -

User Description

User Parent ID This document has never been refreshed. L
IJzer Force Passward Change Administrators ==Administratars SYS_SAPSUPPORT 2012-12-21 11:35:45.0001

|Iser Password Expire @ Data | Cryptographic Officers ==Cryptographic Officers Administrator 2014-05-21 16:49:32.000

User Owner - - m———
== - - |

dgr

Group Name Group Path User Name User Last Logon Time

m

Administrators ==Administrators Administrator 2014-05-21 16:49:32.000

A T T O OE O T O W
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